[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solaris Binaries

I have a Sun Ultra 10 running Debian-Sparc unstable tree, upgraded to kernel 2.4.3. Everything is working fine except for SunOS/Solaris binary compatibility.  I have the kernel compiled with


And I have followed the howto, and placed a complete library/include set in /usr/gnemul/solaris, as well as a whole /etc dir:

total 4
drwxr-xr-x    3 root     root     4096 Apr 26 05:19 solaris
lrwxrwxrwx    1 root     root     19 Apr 26 05:42 sunos -> /usr/gnemul/solaris

However, whenever I try to run a solaris binary, /any/ one, I get this (that is a tar binary from a Solaris 2.6 box) :

mculbert@wintermute:~$ ./tar
bash: ./tar: No such file or directory

Doesn't seem to matter what the binary is, commandline, gui, anything, it just says ./<binary> No such file or directory.
I have tried stracing all of them to see if I can see what it is missing, as I would assume it is not finding /something/ but I get only this from it:

mculbert@wintermute:~$ strace ./tar
execve("./tar", ["./tar"], [/* 28 vars */]) = 0
strace: exec: No such file or directory

I suspect this is quite relevant, but it doesn't help me much, being the first time I've tried cross-binary compatibility.  Can someone clue me in to what I am missing? Thanks in advance.

Mike Culbertson

Reply to: