[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gtk/glib on sparc is broken

On Mon, Nov 13, 2000 at 04:48:34PM +0100, Wichert Akkerman wrote:
> Is it a known problem that I can't install libgtk1.2-dev and
> libglib1.2-dev on sparc potato? The -dev package depends on version
> 1.2.7-2 of libgtk1.2, but only version 1.2.8-1 is available,
> which makes it completely impossible to compile any gnome app
> including the ssh security fix I'm trying to build.

It is a know problem, and the gtk/glib maintainer knows about it.
Basically the sparc packages had to be rebuilt as a binary-only NMU. This
wasn't a problem in the NMU, but in that the binary-all package deps on
the binary-arch packages, were too strict ("= 1.0-1" type deps), which
didn't allow this binary-only NMU to be installed.

He hasn't rebuilt it. It actually needs to be completely rebuilt for all
archs, so that everything has the same version number, or just rebuild the
main one, so that the binary-all packages dep on ${Source-Version} instead
of ${Version}.


/  Ben Collins  --  ...on that fantastic voyage...  --  Debian GNU/Linux   \
`  bcollins@debian.org  --  bcollins@openldap.org  --  bcollins@linux.com  '

Reply to: