[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

maketilo segfault

Hello all,

I have recently installed Debian 2.2 on a Sparc 5 clone (axil).

Since my only SCSI CD-ROM is the poorly working Sony, I did the tftp
install. This worked great.

I am now trying to get my own tftp boot image to work. As an initial test, I
built a new kernel, and am trying to run tilo with it and a ramdisk image I
created. When I run tilo, I get the following:

mcarland@sparc:~$ ./tilo vmlinux.new vmlinux.new2 ramdisk tftpboot

Converting ELF to a.out:

PT 0 Entry: Loadable to 0xf0000000[0x151bbc] from 0x0[0x12b15f] align
PT 0 Entry: Loadable to 0xf0000000[0x151bbc] from 0x0[0x12b15f] align

Sun4c/m/d kernel ... raw size = 1208671, packed size = 523083

Sun4u kernel ... raw size = 1208671, packed size = 523084

Root image ... packed size = 20971520

Images are large. Will load on machines with at least 5M mapped by PROM only

./tilo: line 42:   267 Segmentation fault      `echo $0 | sed
'` sun4c=$1.gz size4c=$SUN4C_SIZE root4c=$SUN4C_ROOT sun4u=$2.gz
IZE root4u=$SUN4U_ROOT root=$3 out=$4

ls: tftpboot: No such file or directory

TILO size =


I tried downloading a a new tilo and maketilo (0.2 from sunsite.org.uk), and
have the same problem (that is why the command above has ./tilo).

Any suggestions?

Can I run tilo to build an image for sun4m only (I have no need for two
kernels to be downloaded)? Is there a good source of documentation to build
an image for tftp booting? I didn't turn much on when building the kernel,
why is it complaining about being large?

My goal is to get this machine to be a diskless/headless router, so I don't
need anything very fancy.

Also, unrelated, I have an Magma sbus quad serial card. I started out
installing OpenBSD since it had a driver for this card, but it was
exceptionally unstable on my hardware, just as the documentation promised.
Does anyone know of a Linux driver for this card? My searches didn't turn
anything up, but it never hurts (too much) to ask. I have the OpenBSD driver
code, and the O'Reilly Linix Drivers book, but if it's already been written
I have bigger fish to fry.


Reply to: