[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Solaris emulation

On Fri, Sep 29, 2000 at 03:08:41PM +0200, Gabor Zoltan Csejtey wrote:
> Hi,
> I tried to use solaris binaries like ls, ufsdump etc.
> I have the precompiled 2.2.17-sun4u kernel from the Debian 2.2 potato version.
> I installed the solaris module and made the directories under 
> /usr/gnemul as in the FAQ http://www.ultralinux.org/faq.html
> I copied the mentioned files and shared libraries. 
> I couldn't find the /etc/ld.so.cache file on the solaris. 
> Can this be the problem?

No, Solaris relies completely on LD_LIBRARY_PATH.

> When I tried to run some solaris binaries I got the following messages:
> e.g. a small program under solaris
> Debian 2.2 linux 2.2.17 kernel:
> ./freemem 
> bash: ./freemem: No such file or directory

I'm not sure about the howto you are reading, but this can't be the right
way to do this. The file is looking for /lib/ld.so to execute it (this
file being from Solaris).

Try this:

cd /solaris
mkdir /usr/gnemul/sbin
cp sbin/sash /usr/gnemul/sbin


That should give you command line and some minimal shell commands.

/  Ben Collins  --  ...on that fantastic voyage...  --  Debian GNU/Linux   \
`  bcollins@debian.org  --  bcollins@openldap.org  --  bcollins@linux.com  '

Reply to: