[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solaris emulation


I tried to use solaris binaries like ls, ufsdump etc.
I have the precompiled 2.2.17-sun4u kernel from the Debian 2.2 potato version.
I installed the solaris module and made the directories under 
/usr/gnemul as in the FAQ http://www.ultralinux.org/faq.html
I copied the mentioned files and shared libraries. 

I couldn't find the /etc/ld.so.cache file on the solaris. 
Can this be the problem?

When I tried to run some solaris binaries I got the following messages:
e.g. a small program under solaris

Debian 2.2 linux 2.2.17 kernel:

bash: ./freemem: No such file or directory

ls -l freemem 
-rwxrwxrwx    1 csejtey  fidi        24844 Sep 29 12:03 freemem

ldd freemem
ldd: can't execute freemem (No such file or directory)

file freemem 
freemem: ELF 32-bit MSB executable, SPARC, version 1, dynamically linked 
(uses shared libs), not stripped

while under solaris I got:

ldd freemem 
        libc.so.1 =>     /usr/lib/libc.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1

I think I missed something. What can be the problem ?

I got similar messages for other binaries as well.
When I removed the solaris module I got the same messages.

Reply to: