[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

trouble: net boot w/ serial console


I recently picked up a Sparcstation 1 from my school's scrap heap.  Not
wanting to lug around the monitor and keyboard, I left them to be hauled
away.  I've got the serial console working just fine, and I'm trying to
boot over the network.  (There's no floppy drive, and I don't have a
spare SCSI CDROM sitting around.)

Anyway, here's what happens: I load tftpboot.img, and the hex numbers
on the console increase until it's loaded the entire image.  Then nothing.
No more data to the serial console.  No response to a <BREAK>.  I've
tried giving the options "serial" and/or "console=ttya" on the boot command
(typed into the ROM monitor), but nothing works.  I get the same results
from the Debian and Red Hat tftpboot.img binaries.  (Not that I would ever
really USE red hat... :) )

Any ideas?

Other things I've already tried: padding the boot image out to a multiple
of 4k has no effect, except that a few more bytes get loaded. loading the
image, then inspecting it using the ROM disassembler, shows that it contains
valid machine code -- but running it has the same effect as above. i have
16 Mb of RAM, a video card, and (I think) a spare SCSI card; removing the
cards makes no difference. the machine still boots SunOS 4.1.4 off the hard
drive, but I can't do anything with that, since it hangs on the NFS mounts,
and I don't have any login passwords anyway.

Brian Johnson

Reply to: