[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: more on the ELC

On Mon, 4 Sep 2000, Jean-Paul Blaquiere wrote:

> after spending too much time trying to tftp install the ELC, I just dumped the
> install on a local disk and installed that way.  It was satisfactory :)
> I don't know why, but manually creating a linux-a.out && root.bin tftp image
> (cat-ing the two together) did not give me the watchdog reset errors.
> However, what I was trying to do was do an nfs-root install. The documentation
> in the install docs was rather minimal.  Has anyone worked on it recently? .... ?
> or can anyone point out a good way to learn it?

	I too ran into similar problems when trying to install potato on
my Sparc ELC. Booting the TFTP image across the network resulted in a
'Data Access Exception'. Instead, I was able to boot with the linux-a.out
image and NFS mount the directory tree found in root.tgz w/o too much
trouble. After that, the rest of the install went fine. I have attached
some notes that detail what I did. Note that 'needle' is the ELC, and
'farstar' is a P100 running Potato with rarp loaded into the kernel, and a
full mirror of potato stored locally.
	Probably not too much help as you have your system setup now, but
might provide good examples for the documentation. TTYL.

|   "For to me to live is Christ, and to die is gain."                    |
|                                            --- Philippians 1:21 (KJV)   |
|   Ryan Kirkpatrick  |  Boulder, Colorado  |  http://www.rkirkpat.net/   |

* Installation of Debian Potato Sparc on needle (Sparc ELC).
**   Connected a 340 MB SCSI HD in external case to needle via SCSI-1 centronics
     to SCSI-2 HD50.
**   Used a type 4 sun keyboard, no mouse. Moniter is part of machine, as
     motherboard is behind the monitor, in the same case. System has 16MB of
**   Turned on HD and machine, fired up and tried to boot, gave it 'Stop-A' and
     it gave me an 'ok ' prompt.
**   Now, had setup tftp and rarp on farstar according to previous methods, arp
     and rarp -s commands w/hostname and MAC. Also, took tftpboot.img and placed 
     it in /boot symlinked to needle's IP address in hex and the suffix,

# /sbin/insmod /path/to/modules/rarp.o
# /sbin/rarp -s talvath 08:00:20:0D:05:13
# /usr/sbin/arp -s 08:00:20:0D:05:13

**   On needle, issued the command 'boot net', it downloaded the tftpboot.img
     file and gave a Data Access Exception.
**   So, got the linux-a.out file from the debian potato distrib for sparc, put
     it in /boot and symlinked it to needle's IP address in hex and the suffix,
**   Did 'boot net' again from needle, and this time it booted  Linux, but
     stopped on mouting root file system, stating it couldn't find the NFS
**   Took the the root.tgz file from the Debian potato distrib and untarred it
     into /boot and it created a directory debian-sparc-root. Symlinked that to
     /boot/, and modified /etc/export to allow access to it, rw and
     no_root_squash from needle.
**   Now, booted with 'boot net nfsroot=/boot/
     nfsaddrs=', where .22 is needle,
     and .4 was farstar.
**   Now we have a boot and start of installation. Nothing much to say about the 
     installation, used a SUN340 disk SUN disk label, which is a 50MB swap
     partition on the end of the disk, rest /. Rest went smoothly, save for an
     error about the sunkeymap file being not a keymap, but did not cause any
**   Then rebooted, and answered a few uninteresting questions, then given the
     opportunity to edit the /etc/apt/sources.list file for
     installation. Switched to another console and FTPed over one from apollo
     and then dropped it in place. The install program had brought up a text
     editor of sources.list, so just told it to quit w/o saving.
**   Found farstar no problem, and all of the package lists. Then generated a
     list of tasks that I could install by. Of course no web server was listed,
     but install pgsql 6.5.3. Apt installed things just fine, no problems there.
**   Installed ssh after that manually, along with apache. Both work fine. 
**   Overall, a pretty good install. Also, apparently the formatting of the
     disk, ext2, can be set for kernel 2.0 compatiblity or not. Did not use the
     compatibility. Aslo, can now use MD5 passwords which allow greater than 8
     characters. :) Enabled them, along with shadow passwords.

Reply to: