[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to find /vmlinuz on an IPX

Thanks all for your answers. I did a try and err-search ;) and finally
got it working. I copied the /boot/vmlinuz-2.2.17-sun4cdm to
/boot/vmlinuz, rmed the /vmlinuz-symlink and copied it also to this
location. And used image=2/vmlinuz (/dev/sda1 is /boot, sda2 is /) and
it worked... I still have to play a little, but I think Leo's way
is the right one.

+-Leonardo Rochael Almeida-(lra@insite.com.br)-[25.08.00 23:05]:
> Put your /boot under 1GB and put everything needed to boot all your OSes
> inside /boot, including all boot sectors from other OSes AND silo.conf
> (put a symlink /etc/silo.conf -> /boot/silo.conf). The reason is that silo
> reads its conf file at runtime (meaning that you don't need to re-run silo
> when you change silo.conf, but also meaning you must keep it under 1GB,
> hence the need to put it under /boot).
> After you do that, don't point silo.conf to a symlink to the kernel, but
> to the kernel proper, so that you don't confuse silo (maybe a symlink to
> the kernel works if both are on the same partition and it's a relative
> symlink, but I haven't tried that).
> so if your /boot is sdX and your kernel is in /boot/vmlinux-2.2.17,
> put image=X/vmlinux-2.2.17

Reply to: