[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

classic & sparc2 install reports (was: Re: problems potato.)

Ben Collins wrote:
> On Sun, Apr 09, 2000 at 06:19:49PM +0200, Taco IJsselmuiden wrote:
> > Hi guys (and girls),
> > Another problem with potato is booting the tftp-images (2.2.8, 2.2.9,
> > 2.2.10) on my IPC and SS1+. The slink-version (2.2.1) works fine...
> > the error: illegal instruction.......
> I haven't been able to get my sparc 1+ to do tftp boots. It continually
> asks for the tftp image, and the server starts the send, but the ss1+
> never tries to accept it. So I haven't tested out those images yet.

Hello Ben,

I did some trial with 2.2.10 on my SparcClassic (sun4m, 24MB, 1GB HD,
CG3+grayscale 19" monitor) using sun4cdm/tftpboot.img:
got several Framing Errors while downloading the tftp image but the image was
bootable (I never got these messages on further installs so I guess it was a
transcient problem with my network cable).
DHCP is working now.
Installing kernel, drivers & base from NFS and netfetch was ok.
System rebooted cleanly.

Several non fatal errors at boot time:

depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/eicon.o
depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/hisax.o
depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/icn.o
depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/sc.o
depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/t1isa.o
depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/t1pci.o

chmod: /etc/resolv.conf: No such file or directory

Still problem with apt & non-US mirror site: cannot specify one other than
non-us.debian.org even in manual mode (bug already filed).

First install of base-files told me to replace /etc/motd conf file.  Not so
good.  I guess it was because out of sync 2.2.10 boot-floppies.

After a reboot, xdm login as root, twm fails to give me the debian menu, so
there is no way under X to launch an xterm.  Need to switch to a VT then run
"xterm -display :0 &", then switch back to X :((( Installing the menu package
solves this problem.  I will file a bug against twm...

> > Here aswell: I'll look into this in about a week or so...
> Thanks, I'de appreciate more feedback on the IPC problem. So far I haven't
> noticed anything on any of my sun4c's.

It's a no go on my sparc2 too (64MB, serial console, 420MB HD):

ok boot net
Boot device: /sbus/le@0,c00000   File and args: 
Booting Linux...

System hangs ;((

I then tried to build old image format using piggyback.  No more success ;((

Now I'm trying to boot with nfsroot method:
ok boot net nfsaddrs= nfsroot=

Houra, system boots up...
Even though I got the following error messages at boot time:

init started:  BusyBox v0.43 (2000.03.31-03:43+0000) multi-call binary
modprobe: modprobe: Can't open dependencies file /lib/modules/2.2.14/modules.dep (No such file or directory)
cannot create /dev/tty4: error 19

dhcp autoconf from dbootstrap does not work: system hangs; need to Break and
reboot ;(( Might be a problem with eth0 already configured by kernel?
Manual configuration of the interface still works.
Further installation is successful :)))

Sorry, I don't have time to do more tests.  It's time to go bed now ;))
I don't know why tftpboot images are not working on sun4c ;((


 Eric Delaunay                 | S'il n'y a pas de solution, c'est qu'il n'y
 delaunay@lix.polytechnique.fr | a pas de problème.   Devise Shadok.

Reply to: