[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with Apt, Slink, and Sparc IPX...

On Sun, 2 Apr 2000, Ben Collins wrote:

> On Sun, Apr 02, 2000 at 09:45:21AM -0500, Ryan Kirkpatrick wrote:
> >         I am trying to update my IPX to the current version of slink via  
> > apt-get, but I am haivng a problem. Whenever I run 'apt-get update' it    
> > connects to the remote server (either ftp.debian.org or http.debian.org)  
> > but then gets stuck and never downloads any files or does anything else,  
> > even after waiting for a long time.
> >         PS. I tried compiling apt 3.18 from source, but it failed. :(
> What was the compile failure?

	If I remember correctly, it was on 'cerr' not being defined (or
something to do with that). I tried to install the current version of
libstdc++-dev package, but it conflicted with libg++-dev package
installed. I didn't really try very hard to make the compile work. 
	Here is the errror:

make[1]: Entering directory `/home/rkirkpat/apt-0.3.18'
make[2]: Entering directory `/home/rkirkpat/apt-0.3.18/apt-pkg'
Compiling contrib/mmap.cc to ../build/obj/apt-pkg/mmap.opic
Compiling contrib/error.cc to ../build/obj/apt-pkg/error.opic
contrib/error.cc: In method `void GlobalError::DumpErrors()':
contrib/error.cc:202: `cerr' undeclared (first use this function)
contrib/error.cc:202: (Each undeclared identifier is reported only once
contrib/error.cc:202: for each function it appears in.)
contrib/error.cc:202: `endl' undeclared (first use this function)
make[2]: *** [../build/obj/apt-pkg/error.opic] Error 1
make[2]: Leaving directory `/home/rkirkpat/apt-0.3.18/apt-pkg'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/rkirkpat/apt-0.3.18'
make: *** [build-stamp] Error 2

	Here is what happened when I tried to install libstc++-dev (prior
to the above compile attempt):

# dpkg -i libstdc++2.9-dev_2.91.66-0slink2.deb 
Selecting previously deselected package libstdc++2.9-dev.
dpkg: regarding libstdc++2.9-dev_2.91.66-0slink2.deb containing
 libstdc++2.9-dev conflicts with libg++272-dev
  libg++272-dev (version is installed.
dpkg: error processing libstdc++2.9-dev_2.91.66-0slink2.deb (--install):
 conflicting packages - not installing libstdc++2.9-dev
Errors were encountered while processing:

	Maybe I should uninstalled libg++-dev and install libstdc++-dev?

|   "For to me to live is Christ, and to die is gain."                    |
|                                            --- Philippians 1:21 (KJV)   |
|   Ryan Kirkpatrick  |  Boulder, Colorado  |  http://www.rkirkpat.net/   |

Reply to: