[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ypbind hangs with IRIX NIS server


Hi all,

I recently installed debian-sparc 2.1 on a Sparc station IPC. Installing
it was as simple as installing debian-i386, you did a good job.

However, when I installed the NIS package and configured the machine to be
a NIS client for an SGI IRIX 6.4 NIS server, it hangs on starting ypbind.
I've booted in single user mode, disabled the NIS client and restarted the
machine. When I tried to start /etc/init.d/nis by hand, ypbind fails at
first (had to kill), but when I start it for the second time, everything
went OK and the machine was nicely humming in the NIS domain.

I tried to explicitly put the name of the ypserver (and also the ypdomain)
in /etc/yp.conf, but that didn't fix the problem.

Am I doing something wrong, or is this a bug in the ypbind binary?


J.A.K. (Erik) Mouw, Information and Communication Theory Group, Department
of Electrical Engineering, Faculty of Information Technology and Systems,
Delft University of Technology, PO BOX 5031,  2600 GA Delft, The Netherlands
Phone: +31-15-2785859  Fax: +31-15-2781843  Email J.A.K.Mouw@its.tudelft.nl
WWW: http://www-ict.its.tudelft.nl/~erik/

Reply to: