[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing debian/sparc in a ultra 1

Quoting Eric Delaunay <delaunay@lix.polytechnique.fr>:
> Hermano Cabral wrote:
> > I've successfully installed the debian/sparc system in my ultra 1 (as a
> > matter of fact, I'm sending this message from it).  However, I was not
> Very good news :-))
> What method did you use ? floppy, tftpboot ?

Floppies.  I'm more familiar with them .

> Maybe a problem with permissions of /dev/fb0 ?
> Try "chmod a+w /dev/fb0".
> Hope this helps you.

Thanks for the tip.  I run strace on Xsun and it told me it was trying
to open /dev/fb0 (among others) read/write but it was not able.  I
then run chmod a+r /dev/fb0 and it worked as a charm (before only root
had read access, although all had write access).  Perhaps the
installation script should make this device world readable by default?
The funny thing is that Xsun was setuid to root but even then it didn't
work.  Go figure...

Another detail is that /dev/mouse didn't exist.  I had to symlink it to
/dev/sunmouse manually.  I've seen in the mailing list archive this is
not the first time it happens.  Another problem with the installation
script?  I'd be happy to fix if someone gives me some directions from
where to start.

I'm trying now to compile windowmaker 0.51, since the binary package was
not in potato (for sparc, the i386 architecture had this package), but
there is a couple of (seemingly) minor problems.  I'll look over them

I'd say the installation was smoother than I expected.  Kudos to the
Debian/Sparc team.  I was afraid I'd have to use UltraPenguin instead of
Debian.  UP seems to be a fine distribution but I'd like to stick with
Debian since that's what I use at home.  I'll be very happy though if I
can get the afs client to work with Debian.

Well, enough for today.  Thanks again,

Hermano Cabral

Reply to: