[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sparc boot troubles

Steve Dunham wrote:
> Eric Delaunay <delaunay@lix.polytechnique.fr> writes:
> > Steve Dunham wrote:
> > > Eric Delaunay <delaunay@lix.polytechnique.fr> writes:
> > > > Steve Dunham wrote:
> > > > > FYI: I've generated a CD, but I'm having a few problems with it.  In
> > > > > particular, it's not able to mount the initial ramdisk.  I am using
> > > > > the same kernels that I used to make the previous CD's - the only
> > > > > difference is that now I am trying to use a.out kernels.
> > > 
> > > > Do you see a message in the boot log like "ramdisk overwritten, ..." ?
> > > > I got it when my 2.0.35 kernel was to big, thus disabling the use of ramdisk.
> > > No I don't see this message.  I've tried using the 1.5MB
> > > (uncompressed) kernel from UltraPenguin and the silo binaries from
> > > UltraPenguin, booting from a hard drive (I give it the kernel name,
> > > initrd filename, and root=/dev/ram) and it still doesn't see the RAM
> > > disk.
> > > This is on my Sparc20, it does work on the Ultra.  I'm starting to
> > > suspect that initrd loading is broken in silo.  Can you get initrd
> > > loading to work from SILO?  (Not TFTP.)
> > I used silo 0.8.5 to boot with initrd on a sparc classic without problems so
> > far (either 2.0.35 from my bootdisks or your 2.2.1 kernel).
> > Don't know why it fails.  Something's wrong with sparc20 ?
> This only happens on sun4m machines.  (I also tried a sparc 2 and a
> sparc10 last night and the SS2 worked, but the SS10 didn't.  I went
> further and tried silo 0.8.1 with the same result.)

My sparc2 is really sensitive to floppy quality.  I tried Maxell MF2HD without
success but have had no problem using Memorex 2SHD !
(with the former medium I get read error in block 65)

However, I'm still experimenting another problem: it cannot load (or mount)
the ramdisk from the root floppy.  I get the following messages on screen and
the system if stuck here:

  RAMDISK: Compressed image found at block 0
  EXT2-fs warning: checktime reached, running e2fsck is recommended
  VFS: Mounted root (ext2 filesystem).
  Freeing unused kernel memory: 40k code, 4k data

I guess the ext2fs warning is coming from my hard disk where I installed a
previous system.  Therefore it seems it doesn't mount the ramdisk at all :-(

I also tried to tftpboot with no more success: still cannot mount the ramdisk.

It seems there is a problem in the root.bin image.  I did a trial with the
latest released root image (2.1.6-990202): works like a charm.

Because of this problem, I will not upload new bootdisks before the end of the
week.  I'll try to investigate and hope to be ready to upload them next monday
or tuesday.


 Eric Delaunay                 | "La guerre justifie l'existence des militaires.
 delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)

Reply to: