[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

"Configure the Base System" goes into an infinite loop. Why?

Hi All!

While trying to install Debian Sparc (boot-floppies version 1999-02-02) on
SparcClassic today, I've run into the following problem. Everything went more
or less fine till I was asked to "Configure the Base System". If I press
'Enter', the system probes the floppy drive (I can just here this) and if
there is a floppy there, ejects it, then returns to the original start-up menu
with choice of the display. I can then chose one, press "Continue with
installation", read "Release notes" and end up with the same request:
"Configure the Base System".  I've tried to go through this cycle more than 5
times choosing color and monochrome displays --- no change. If I bypass this
configuration, make the system bootable from the hard drive etc., then after
the boot I have the requests to finish the configuration before going any
further and I return to the same state.

Apparently, not everything else is fine either. When the drivers are installed
from the floppy, I have the following error at the end: "Floppy Error! The
attempt to extract the Drivers Floppy failed." But this is NOT a floppy
problem. I've try to use three different floppies from different manufactures
with different age and storage places, which worked fine with other images,
but the error is the same. Finally, I've made a dump (on the second VC) of the
floppy and compared with the original drv1440.bin file --- they are the same. 
After the error, the installation proceeds as if nothing has happened (is it a
bug?) till that notorious "Configure...".

What else I've tried to do: I've install the base system using NFS, floppies
and pre-mounted file system. No change. I've also tried to install "Kernels
and driver modules" using NFS. Then I go to the initial screen with display
choice immediately. I even tried the install floppies by Steve Dunham (found
on ftp://ftp.cse.msu.edu/pub/debian/install.new). drv1440.bin makes no change,
and resc1440.bin (from sun4cdm) produces "Illegal Instruction" error.

What can be wrong with this? I'm using the very general SparcClassic with 48
megs of memory. The only difference is that it has an external hard-drive. But
kernel finds it nicely, formats it etc. without problems. It also has Solaris
installed in the first partition (the second is swap, the third is "whole
disk" and the forth is for Linux) but I don't believe it can matter.

Thanks in advance for any help!

   --- Shurik.

Reply to: