[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel 2.2 & debian bootdisks woes (was: Re: new bootdisks coming soon)

Steve Dunham wrote:
> Eric Delaunay <delaunay@lix.polytechnique.fr> writes:
> > [1  <text/plain; US-ASCII (7bit)>]
> > 
> > I hope I will release a new set of bootdisks thrusday evening (need to update
> > my local mirror one more time before).
> > I just tried a bit to deal with 2.2 kernels with no success.  It don't eject
> > floppy automatically after the rescue disk was read and I displays the
> > following message:
> >  Warning: unable to open an initial console.
> > when booting from the net (tftpboot.imh method).
> That's odd, I've successfully used late 2.1.x kernels with the old
> root image.  I'll take a look at your images tomorrow.  (Technically,
> /dev/console should be major 5 minor 1 with the new kernels, but I
> don't know if it makes that much of a difference.)

It was using a serial console display.

Anyway, I'm now using my latest bootdisks merged with a 2.2.0 kernel on
SparcClassic with linux console (cg3 + monitor) still with no success.
It displays the first dialog box (choosing color or mononochrome) but the
keyboard is not responding at all (not arrow keys, no enter, ...) :-(
However, I can switch to other VTs (via ALT+F?) and in all of them but the
first, the keyboard is working fine.
Ok, since the second VT is working, I launched dbootstrap in it.  It seems to
work well: I can do configuring the keyboard, partitioning the hard drive, and
so on.
I just run in trouble when I run a subshell from dbootstrap.  Outputs of the
programs I run from the shell are going to the second VT as usual, but the
shell's prompt is not displaying in this VT but in the first one !!!
stderr outputs are sent to the first VT as well.
In the first VT I can see the following message displayed at ash starting

  sh: can't access tty; job control turned off

Any hints ?
Thanks in advance.

PS: I also tried to boot with tftp + nfsroot method and fixed /dev/console to
    be "char major 5 minor 1" device with no more success.  Same behavior :-(

PPS: my kernel was built with kernel-source 2.2.0 & kernel-patch-2.2.0-2 for
     sparc if it's matter.

 Eric Delaunay                 | "La guerre justifie l'existence des militaires.
 delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)

Reply to: