[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: NIS and gdbm

Stephan Wiehr <lynx@fsinfo.cs.uni-sb.de> writes:

> Anybody who got NIS working? 
> I tried to setup a Sparc1/Debian-Linux as NIS client (version 3.3.1-1) with
> a Sparc2/SunOS4.1.3 as NIS server and it just wouldn't work, other
> SunOS4.1.3 clients work fine. 

Works fine here.  The servers are a collection of UltraSparcs running
Solaris.  I have a Sparc20 and an Ultra5 running Debian as clients.

> Trying to recompile NIS from the potato-sources resulted in this:

> checking for gdbm_open in -lgdbm... no
> checking for dbm_open... no
>  You need the GNU GDBM library or NDBM support for this package !

You need the libgdbmg1-dev package.

> gdbm is definitely installed, Version 1.7.3-26
> Anyway I tried to recompile gdbm. Result:

> test -f gdbmclose.c -a -f debian/rules
> test root = "`whoami`"
> test -f gdbmclose.c -a -f debian/rules
> CONFIG_SITE="" CC="sparc-linuxlibc1-gcc" ./configure
> --cache-file=configc1.cache
>  --prefix=/usr/sparc-linuxlibc1/
> creating cache configc1.cache
> checking for gcc... sparc-linuxlibc1-gcc
> checking whether the C compiler (sparc-linuxlibc1-gcc  ) works... no
> configure: error: installation or configuration problem: C compiler cannot
> create executables.

You need the altdev stuff to recompile the GDBM package.


Reply to: