[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: slink on SLC: `You must upgrade dpkg'

Alexander Jolk <jolk@ap-pc513b.physik.uni-karlsruhe.de> writes:

> James Troup writes:
>  > Alexander Jolk <jolk@ap-pc513b.physik.uni-karlsruhe.de> writes:
>  > 
>  > > Unpacking bison (from bison_1.25-12.deb) ...
>  > > 
>  > > You must upgrade dpkg before installing this package.
>  > 
>  > Cool, you've somehow got a dpkg (<<; that's impressive.
> How come dpkg thinks it is <<  dpkg --version says
>, as does `dpkg --list dpkg'.  Something's wrong, but what?

Either you have an old version of dpkg hanging around somewhere or
sparc's dpkg is seriously FU (unlikely); I suggest you hunt around
looking for rogue copies, and see what dpkg is actually run by root
(i.e. `type dpkg' and `dpkg --version').


Reply to: