[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Dpkg-devel

>I have been trying to compile a kernel on a sparcstation 10, I have
>installed all the kernel source and patched aswell.
>When I try to install the dpkg-dev packages to run make-kpkg I get the
>following error:
>gnome# dpkg -i dpkg-dev_1.4.0.22.deb
>(Reading database ... 18925 files and directories currently installed.)
>Unpacking dpkg-dev (from dpkg-dev_1.4.0.22.deb) ...
>dpkg: error processing dpkg-dev_1.4.0.22.deb (--install):
>trying to overwrite `/usr/doc/dpkg/packaging.html/index.html', which is
>also in
>package dpkg
>dpkg-deb: subprocess paste killed by signal (Broken pipe)
>Errors were encountered while processing:
>Has anyone seen this before? I have tried removing all packages related to
>dpkg, aswell as dpkg-dev (even though it is not installed).
>I have also tried removing the index.html file, and the entire
>/usr/doc/dpkg directory tree.

That particular file has moved from dpkg to dpkg-deb in
Until we get a dpkg_1.4.0.22 for sparc, you have to do

dpkg --force-overwrite -i dpkg-dev_1.4.0.22.deb

(or find an older dpkg-dev). Also, I've noticed some odd behaviour of
gzip complaining when running dpkg on 2.1.9x kernels (haven't had the
time to localize the problem).


 -- Of course I'm crazy, but that doesn't mean I'm wrong.
Anders Hammarquist   |       Mud at Kingdoms        | iko@netg.se
NetGuide Scandinavia |   telnet kingdoms.se 1812    | Fax: +46 31 50 79 39
http://www.netg.se   |                              | Tel: +46 31 50 79 40

To UNSUBSCRIBE, email to debian-sparc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: