[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [DSA 1356-1] New Linux 2.6.18 packages fix several vulnerabilities

dann frazier <dannf@debian.org> writes:

> If you are using the apt-get package manager, use the line for
> sources.list as given below:
> apt-get update
>         will update the internal database
> apt-get upgrade
>         will install corrected packages

This won't work unless there are updated linux-image-2.6-* packages in
security, will it?

canardo:/tmp# apt-cache policy linux-image-2.6-686 linux-image-2.6.18-4-686 linux-image-2.6.18-5-686; apt-cache show linux-image-2.6-686
  Installed: 2.6.18+6
  Candidate: 2.6.18+6
  Version table:
 *** 2.6.18+6 0
        700 http://ftp.no.debian.org etch/main Packages
        100 /var/lib/dpkg/status
  Installed: 2.6.18.dfsg.1-12etch2
  Candidate: 2.6.18.dfsg.1-12etch2
  Version table:
 *** 2.6.18.dfsg.1-12etch2 0
        700 http://security.debian.org etch/updates/main Packages
        100 /var/lib/dpkg/status
     2.6.18.dfsg.1-12 0
        700 http://ftp.no.debian.org etch/main Packages
  Installed: (none)
  Candidate: 2.6.18.dfsg.1-13etch1
  Version table:
     2.6.18.dfsg.1-13etch1 0
        700 http://security.debian.org etch/updates/main Packages
Package: linux-image-2.6-686
Priority: optional
Section: admin
Installed-Size: 32
Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
Architecture: i386
Source: linux-latest-2.6 (6)
Version: 2.6.18+6
Depends: linux-image-2.6.18-4-686
Filename: pool/main/l/linux-latest-2.6/linux-image-2.6-686_2.6.18+6_i386.deb
Size: 2042
MD5sum: 742460ce676544cf67ed1913cf95365e
SHA1: 06af925335b865f1f044ef00a23c4dcb855302c6
SHA256: 883e11c1e2196f3632c75fdbd454797cad729935de841ec40c3e053560406068
Description: Linux kernel 2.6 image on PPro/Celeron/PII/PIII/P4
 This package depends on the latest binary image for Linux kernel 2.6 on
 Pentium Pro/Celeron/Pentium II/Pentium III/Pentium 4 machines.
Tag: admin::kernel

It's well known that most short people have surfboards.

Reply to: