[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debianutils / coreutils


I tried to upgrade debianutils from 1.16   to   1.16.2woody1
and retreived the following error:

(Reading database ... 111696 files and directories currently installed.)
Preparing to replace debianutils 1.16 (using .../debianutils_1.16.2woody1_i386.deb) ...
Unpacking replacement debianutils ...
dpkg: error processing /var/cache/apt/archives/debianutils_1.16.2woody1_i386.deb (--unpack):
 trying to overwrite `/bin/readlink', which is also in package coreutils
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ack! Something bad happened while installing packages. Trying to recover:
Press return to continue.

It's this package:
i   --\ coreutils             5.0-4     <none>      Description
coreutils - The GNU core utilities
This package contains the essential basic system utilities.
Specifically, this package includes:
basename cat chgrp chmod chown chroot cksum comm cp csplit cut date dd df dir dircolors dirname du echo env expand expr factor false fmt fold groups head hostid id install join link ln logname ls md5sum mkdir mkfifo mknod mv nice nl
nohup od paste pathchk pinky pr printenv printf ptx pwd rm rmdir seq shred
sleep sort split stat stty sum sync tac tail tee test touch tr true tsort tty
uname unexpand uniq unlink users vdir wc who whoami yes
  Essential: yes
  Priority: required
  Section: base
  Maintainer: Michael Stone <mstone@debian.org>
  Compressed size: 0
  Uncompressed size: 6431k
  Source Package: coreutils
  --\ PreDepends
    --- libc6 (>= 2.3.1-1)
  --\ Conflicts
    --- stat
  --\ Replaces
    --- textutils
    --- shellutils
    --- fileutils
    --- stat
    --- debianutils (<= 2.3.1)
  --- Packages which depend on coreutils
  --\ Versions
i   5.0-4

Next i tried to fetch coreutils source, but retreived:
 r: apt-get source coreutils
Reading Package Lists... Done
Building Dependency Tree... Done
E: Unable to find a source package for coreutils

In sources.list i have these pointers:
# stable (Woody):
deb-src ftp://ftp.de.debian.org/debian/ woody contrib main non-free
deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

dpkg -L shows no /bin/readlink file included in debianutils.
Why or what trying to overwrite then ?

Somebody can help me ?


Reply to: