[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to reduce sid security

I will try to explain again.  This is not an urgent problem, but it is
highly irritating.

I have an older PC running Debian Stable (Woody, 2.2.20).  My new PC
is running Debian Unstable (Sid, 2.4.18-bf2.4).  I am using the latter
for development, and my wife uses it for her e-mail, e-bay, etc.

Both machines are connected through a Linksys router/firewall to DSL,
and the Linksys is in its default mode which lets nothing through
(except returning packets, etc), doesn't answer pings, etc.

I would like for these two Linux systems to completely trust each
other so I can run remote X (XDMCP), using the KDE3 service on the
faster, more up-to-date PC, for my window manager on the older PC. 
You cannot do this through ssh as far as I can tell, and it would
create quite a bit of overhead even if you could.

I have gotten ssh, rsh, rlogin, ftp to work, but not remote X.  

I have tried all of the ideas given in this thread.  

I went carefully through the HOWTO on XDMCP and made all the changes
given there on both hosts.  But I still get the message "Error: Can't
open display: woody:0.0" after I do the xhost + on Woody, do a rsh to
Sid, and try xclock -display woody:0.0 .

I just noticed I can do telnet from Sid to Woody, but not to Sid from
Sid, nor to Sid from Woody.  Both have the same lines in
/etc/inetd.conf about telnet, and both have 'LISTEN' in the 'netstat
-l | grep telnet' output.

I made sure that ipchains is in the ACCEPT mode by doing ipchains -F
on Woody.  I can't find the firewall on Sid - maybe that is the

I probably will post this in another debian group, but I think it is a
security setting that causing the problem.

 Thanks for any ideas.
 Boyd KO4WK
 Zech 4:6

Reply to: