[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SNORT not adding entries to snort/portscan ???

On Sat, Nov 30, 2002 at 06:25:47PM -0800, Andris Kalnozols wrote:
> Is this an example of what you mean?
>   /usr/sbin/sendmail: /lib/libc.so.6: version `GLIBC_2.3' not found
> 		      (required by /usr/sbin/sendmail)
> After `apt-get' upgraded sendmail to 8.12.6, this error appeared.
> As I recall from another Debian list, the response from whoever
> compiled this version was something like "Oops, stuff happens
> in the testing distro" but, a month later, there's still no working
> replacement.  How does one go about fixing this kind of problem?
> Andris

More basic than that. You will find packages that refuse to build without
pulling in a new libc6 they don't even need. This comes from a dependency
for say:

	>= libc6_2.2.5-13

when there is actually no reason that anything after

	>= libc6_2.2.1-1

would have worked. Perhaps there are good reasons for requiring the absolute
latest revision. Usually there are not unless you really do intend to 
upgrade a large chunk of your system. 

The case you are describing is far worse. It's broken period, not
just an annoyance and the cause of loads of unnecessary package
dependency caused upgrades.

Reply to: