[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Execute binaries from an encrypted file system [SOLVED]

Thanx, you gave me the idea to solve this. I forgot that I've added the
user option in '/etc/fstab' (stupid me). "user" implies noexec, so you
have to add exec after the user option.


On Mon, 2002-11-25 at 14:32, DEFFONTAINES Vincent wrote:
> > From: Haim Ashkenazi [mailto:haim@consonet.com]
> > 
> > When making an encrypted file system (AES on both occasion) everything
> > works great except I can't run binaries (or even shell scripts without
> > running "bash <script>") that are inside the encrypted file system.
> > there is no "noexec" option in "fstab", and I even tried to add exec
> > option but it didn't work. 
> > So is this a limitation of the encrypted file system or there is a way
> > around that?
> Not answering your problem, but I have the same behaviour here. (Debian sid,
> kernel 2.4.19)
> noexec is not mentionned in my /etc/fstab for that filesystem
> Thouh "mount" reports (as the /etc/mtab does too):
> /path/to_file/cryptofile on /mnt/crypto type ext2 \
> (rw,noexec,nosuid,nodev,loop=/dev/loop0,encryption=aes,user=myuser)
>     ^^^^^^
> Looks like the noexec option is automatically added at mount time?
> Vincent
> -- 
> To UNSUBSCRIBE, email to debian-security-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: