[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Using PAM with SFS

I'm using the libpam-sfs PAM module, which lets users authenticate at
login and for importing directories in one single step.  The binary
.deb that comes with Woody works fine.  But...

Short version: when I try to compile it from source I hit a wall.
Anybody managed to compile it?

Long version:

  $ apt-get source libpam-sfs
  E: Unable to find a source package for libpam-sfs

So I got it from SourceForge (libpam-sfs-0.2.2.tar.gz), unpacked it
and run dpkg-buildpackage.  It dies with:

  make: ./configure: Command not found
Ooops, there is no configure.  But there is autogen.sh.  I run
autogen.sh and then dpkg-buildpackage again:

  checking for main in -lgmp3... no
  configure: error: gmp3 library not found


  $ dpkg --status libgmp3
  Package: libgmp3
  Status: install ok installed

Let's see...

  # ln -s /usr/lib/libgmp.so.3 /usr/lib/libgmp3.so
  # dpkg-buildpackage

Ok, past libgmp3, but now it ends with...

  checking for main in -lsfscrypt... no
  configure: error: sfscrypt library not found

But debian/rules does call configure --with-sfs-libdir=/usr/lib/sfs,

  $ ls /usr/lib/sfs/libsfscrypt.*

What am I doing wrong?  BTW, I've tried to compile libpam-sfs on RH
7.2 and 7.3 too with no success, either (though the problem there
seems related to nana-config.h).  I'm setting a file server in an
environment where clients' roots aren't necessarily trusted and
phisical access to the network is not restricted, so NFS isn't the
healthiest choice and I have found no alternative beyond SFS that is
reasonably gentle to sysadmins.  (No, after LDAP plus Samba there's no
way I'm grokking Kerberos for AFS. ;->)

Thank you for any help,


Reply to: