[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SSH install in Woody

Steve Greenland, 2001-Sep-10 10:50 -0500:
> On 10-Sep-01, 03:34 (CDT), Colin Walters <walters@verbum.org> wrote: 
> > Jeff Coppock <jcoppock1@home.com> writes:
> > 
> > > I'm having trouble getting ssh installed on my new woody system.
> > > I'm getting segmentation faults during the ssh-keygen process.  I
> > > can't find any reason for this.
> > 
> > Are you familiar with GDB?  You should download the source to the ssh
> > package (apt-get source ssh), then rebuild it with debugging
> > information, get a backtrace using gdb, then include that information
> > in a bug report against the ssh package.
> As a simpler first step, you can install "strace" and/or "ltrace" and run
> ssh-keygen under them and see how far it's getting...it may or may not help,
> but it's a lot faster/easier than getting gdb running.
> Additionally, if the ssh debian/rules file has been properly set up, you
> can rebuild with debugging simply by 
> apt-get source ssh
> cd ssh-<version>
> DEB_BUILD_OPTIONS="debug,nostrip" debian/rules build 
> (or "... debian/rules binary" if you want a new .deb package, instead of
> just an ssh-keygen with debugging info)
> Steve

I ran ssh-keygen with strace and found that the seg fault occurs
after /dev/urandom is opened, then closed, and the "brk0x..."
lines come out.  All the libs are present and appear fine.  I ran
ssh-keygen with gdb too, and it doesn't have the debug stuff
compile in.  I just a message stating the seg fault occurs when
working with libcrypto and libc.

I'm going to try compiling from source and see how that goes.



Jeff Coppock		Nortel Networks
Systems Engineer	http://nortelnetworks.com
Major Accts.		Santa Clara, CA

Reply to: