[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apache & modauth_mysql woes



Hi,
Sorry for the cross-post to both debian-users and debian-security, but I
am desparate to get this working.

Has anyone been able to get mod_auth_mysql 2.2 compile and working on woody?
I get mod_auth_mysql compiled using apxs, but it fails when I try to start
apache.

The apxs command line is:
apxs -c -I/usr/include/mysql -L/usr/lib/ -lmysqlclient mod_auth_mysql.c

here's what i get for output:
edge:/home/str8edge# apxs -c -I/usr/include/mysql -L/usr/lib/ -lmysqlclient mod_auth_mysql.c
gcc -DLINUX=22 -DEAPI -DTARGET="apache" -I/usr/include/db1 -DUSE_HSREGEX -DUSE_EXPAT -I../lib/expat-lite -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fpic -DSHARED_MODULE -I/usr/include/apache-1.3 -I/usr/include/mysql  -c mod_auth_mysql.c
gcc -shared -o mod_auth_mysql.so mod_auth_mysql.o -L/usr/lib/ -lmysqlclient -lc -lm -lcrypt -ldb1 -ldb

Then I cp the mod_auth_mysql.so file to /usr/lib/apache/1.3/ and add 
LoadModule auth_mysql_module /usr/lib/apache/1.3/mod_auth_mysql.so to my
/etc/apache/httpd.conf file.

When I run apachectl start I get the following
edge:/home/str8edge# apachectl start
Syntax error on line 252 of /etc/apache/httpd.conf:
Can't locate API module structure `auth_mysql_module' in file /usr/lib/apache/1.3/mod_auth_mysql.so: /usr/sbin/apache: undefined symbol: auth_mysql_module
/usr/sbin/apachectl start: httpd could not be started

I am using woody, apache -v returns
Server version: Apache/1.3.20 (Unix) Debian/GNU
Server built:   Aug 23 2001 11:23:40

I have tried to complile mod_auth_mysql from source using the traditional
./configure, make, make install, but that will not compile completely without
massive doctoring of the configure.in file.

I'm definitely in over my head.. Any help would be appreciated.

Thanks,
David

Attachment: pgplyoTajiqod.pgp
Description: PGP signature


Reply to: