[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#545906: Debian S390 Install Failed to create a file system during installer process

On Tue, Feb 16, 2016 at 08:46:58PM -0800, Martin Michlmayr wrote:
> * HAND, RAY <ray.hand@hp.com> [2009-09-09 21:09]:
> > Package: Partman-ext3
> > Version:  2.6.26-2
> > 
> > In the partition disks screen I get the error:
> > 
> > The ext3 file system creation in partition #1 of DASD 0.0.0300 (ECKD) failed.
> I'm sorry that nobody responded to the bug report you filed back in
> 2009.  Do you still have access to this system?
> s390: maybe you can take a brief look at the logs to see if that's
> still relevant.
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=545906
According to the syslog, partman tried to access beyond the size of the
DASD.  Because partman-ext3 works today, I suspect that the problem has
been solved in last years.  I can only suspect about the root case but
I ran into a similar issue (other work area) where the calculation of
the DASD size was wrong due to incorrect use of ioctl.  There are ioctl
that return the size in bytes and blocks (I think there was a 32 and 64
bit variant, which returned in different units).  So the size calculation
was broken and I received the same error message.  Maybe partman-ext3
was also affected by this change.  Not sure.

For short: I would suggest to close this bug and re-open if the problem
still persists.

Thanks and kind regards,

Reply to: