[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian-390 / Hercules Problems

On Mon, Feb 17, 2014 at 9:27 PM, Stephen Powell <zlinuxman@wowway.com> wrote:
On Mon, 17 Feb 2014 15:19:13 -0500 (EST), David Clements wrote:
> Stephen Powell wrote:
>> ...
>> The standard Debian package for
>> Hercules, 3.07, does not support an Open Systems Adapter Express in QDIO
>> mode, so that's the end of that.
>> I've never tried to use znetconf.  For that matter, I've never tried to use
>> lsqeth either.  But it does seem to be included in the standard s390-tools
>> package under Debian.  Here is some output from my system:
>> # whereis lsqeth
>> lsqeth: /sbin/lsqeth /usr/share/man/man8/lsqeth.8.gz
>> By the way, I'd be interested to hear your opinion of my "Debian Under
>> Hercules"
>> web page at http://users.wowway.com/~zlinuxman/hercules.htm .
> I'm using hercules 4.0, this version supports qeth layer2, I have debian
> wheezy running with qeth and I'm currently testing layer3 qeth.
> What version of debian-390 are you using, the current stable that I have
> installed, only contains a minimal s390-tools package and I have yet to
> find a full debian s390-tools package.

The system quoted above is a jessie system (testing).

Debian, especially Debian stable, tends to be a "trailing edge"
distribution.  Many Debian packages are substantially behind the latest
upstream release, hercules itself being a good example (3.07 vs 4.0).
GNU parted is another example.  It is way behind.

s390-tools is no exception.  The release used in jessie, 1.17.1,
is way behind the latest upstream release, which at the time of this
writing is apparently 1.24.1.

Perhaps the tools you are looking for don't exist in 1.17.1.
Debian wheezy (stable) uses 1.16.0, even older.  Make sure that the
documentation you're looking at (Device Drivers, Features, and
Commands?) was written for release 1.16.0 or 1.17.1, depending on
which Debian "release" you are running.

If you're looking for a bleeding edge distribution, look elsewhere.

I speak here as an experienced Debian user, not as any kind of
official spokesman for Debian.

  .''`.     Stephen Powell
 : :'  :
 `. `'`

I'm in the process of installing Jessie, I'll see how I get on with that system. As far as the znetconf, lsqeth tools are concerned they were in S390-tools package at 1.10.0, so they should have been correct in Wheezy. I'll stay with debian, it is all I need in a distro.

Dave Clements.

Reply to: