[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wheezy installer images fail on hercules

On Sat, May 19, 2012 at 07:19:32PM +0200, Andreas Metzler wrote:
> FYI I just tried to install wheezy on hercules, using
> http://ftp.at.debian.org/debian/dists/wheezy/main/installer-s390/current/images/generic/*
> with http://www.josefsipek.net/docs/s390-linux/hercules-s390.html
> I got "ERROR: No CTC or ESCON connections" although devlist showed
> otherwise.
> Switching to
> http://ftp.at.debian.org/debian/dists/stable/main/installer-s390/current/images/generic/*
> (without any changes to my setup, I just switched images) worked.

Indeed, thanks for the report.  It seems that the kernel driver switched from
cu3088 to ctcm (the driver name is hardcoded in s390-netdevice).  Furthermore I
only see «/sys/bus/ccw/devices/0.0.0a00», i.e. just one device instead of its
write partner 0.0.0a01.  The same issue has been fixed in sysconfig-hardware
with #566632, but there both devices turned up.

Stephen, Waldi, do you know of a corresponding upstream change apart from the
driver renaming?

Kind regards
Philipp Kern

Attachment: signature.asc
Description: Digital signature

Reply to: