[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Squeeze install successful, now a NIC / OSA / eth0 problem

Ok, here I am again..... I got Squeeze squeezed onto 4 3390-27's and IPL'd the newly installed system from where the zIPL loader had put it.
Everything was going smoothly until it came time to deal with the eth0 interface, and then out came this..... ( from the console log )
[   41.260175]  dasde:VOL1/  LX0296: dasde1
[   41.317430] qeth: loading core functions
[   41.757291] qeth: register layer 3 discipline
[   41.777369] qdio: 0.0.e205 OSA on SC 12 using AI:0 QEBSM:0 PCI:1 TDD:0 SIGA:RWSAO
[   41.815528] qeth 0.0.e203: Device is a OSD Express card (level: 035f)
[   41.815541] with link type OSD_100 (portname: )
[   41.819180] qeth 0.0.e203: Hardware IP fragmentation not supported on eth0
[   41.821213] qeth 0.0.e203: VLAN enabled
[   41.822182] qeth 0.0.e203: Multicast enabled
[   41.826185] qeth 0.0.e203: IPV6 enabled
[   41.828183] qeth 0.0.e203: Broadcast enabled
[   41.829197] qeth 0.0.e203: Setting up broadcast echo filtering for eth0 failed
[   41.829254] qeth 0.0.e203: Using SW checksumming on eth0.
[   41.829311] qeth 0.0.e203: Outbound TSO not supported on eth0
[   42.087099] udev[178]: renamed network interface eth0 to eth5
Notice how "eth0" gets renamed to "eth5"  ( this copied version gets incremented by "1" every time I IPL .. don't know why either )
Anyway... a few lines later, it wants to work with "eth0" which is now no longer available, having been renamed to something else, and
we get this :
Setting kernel variables ...done."
Configuring network interfaces...SIOCSIFADDR: No such device"
eth0: ERROR while getting interface flags: No such device"
SIOCSIFNETMASK: No such device"
SIOCSIFBRDADDR: No such device"
eth0: ERROR while getting interface flags: No such device"
eth0: ERROR while getting interface flags: No such device"
Failed to bring up eth0."
So... being the Linux Crash-Test Dummy that I am ....
why is "eth0" being renamed at every IPL ?  which causes the apparent startup of "eth0"
to fail a few lines later ?   I tried doing a "ifup eth5" during this most recent IPL and it acted
as if it had no idea what "eth5" was.
Any suggestions or guidance will be appreciated, as always.  Thanks.
This is a z800 with both FENET and GIGABIT OSA cards, I've tried both and they give this
same error problem.  I remember during the install it asked if I wanted to use "Layer 2" or
"Layer 3" and I gave it the "default".

Reply to: