[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Access to s390 porter machine


on Thu, Apr 05, 2012 at 07:58:11AM +0000 you and possibly Stephen wrote the
> > take the Debian s390 port some time to recover from his loss.
> > 
> > Since Debian is an all-volunteer organization, and sincete we have
> > no corporate sponsorship from IBM for system z, IBM System z servers are
> > hard to come by for the Debian project.  (Not too many private individuals
> > have a 64-bit mainframe in their basements.)  Frans himself used
> > the Hercules emulator running under Linux on an Intel box, I believe,
> > to do his work, and I suspect (but do not know for certain) that
> > the production build servers do as well.  Frans was doing the
> > daily builds of the squeeze Debian installer for the s390 platform
> > himself, the last I knew.  I just tried the link myself:
> > http://people.debian.org/~fjp/d-i/s390/images/daily/ and got a
> > "404 - not found" error; so we have no e builds.  That
> > issue needs to be addressed.

that's now available in the usual place[1] since quite a while.  FWIW
debian-s390@lists.debian.org is the right point to ask questions.

> > I have access to a real IBM mainframe owned by my employer, and I
> > can sometimes test things for Debian, if it is in my employer's
> > interests to do so; but I am not in a position to offer a "porter
> > box" to Debian.  It doesn't belong to me.  I run Debian for s390
> > in a virtual machine under z/VM; so if there's anything VM-specific
> > that needs tested, I might be able to help.

Well, we do have a porter box, but it does not allow for low-level installation

> I want to install Debian on Mainframe z10 EC, I was successfully booted it
> through DVD but the problem is that it is not detecting any of the OSAs. And
> while installing SUSE I didn't face any problem.
> Please guide me how to install it on LPAR.

There's a problem with DASD picking when seeing more than 20 devices in the
LPAR.  The trouble I had with OSAs was that too many were detected and hence
you are unable to pick the right ones if they don't come first, because of the
way the chooser works at that point.  One way to workaround that would be to
edit the IOCDS to hide the irrelevant devices (you can reenable them
post-installation of course).  Installation in z/VM with the device numbers
that should be used in LPAR mode is usually the easiest way, but I understand
that this is not available for those trying Debian directly in LPAR mode.

Kind regards
Philipp Kern

Attachment: signature.asc
Description: Digital signature

Reply to: