[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Linux/390 under z/VM 4.2.0] CP works forever (Lenny)

On Thu, 07 Apr 2011 11:49:00 -0400 (EDT), Christian Boitet wrote:
> At 22:23 -0400 5/04/11, Stephen Powell wrote:
>> On Tue, 05 Apr 2011 20:50:23 -0400 (EDT), Christian Boitet wrote:
>>> Bonsoir Stephen,
>>> we are trying to upgrade some virtual machines
>>> under a 2004 RedHat Linux/390 to an up-to-date Debian
>>> ...
>>> Could you help?
>>> ...
>> A multiprise 3000 model H30?  Isn't that an ESA/390 processor?
>> In other words, it's not capable of z/Architecture mode, correct?
> Yes, you are 100% right, our fault. I should have 
> known, because I read somewhere we should not use 
> Squeeze on a H30. We actually experienced 
> recently similar problems on Mac OSX with 
> programs in 32 and 64 bits, in ANTLR, and kernel 
> in 32 bits or 64 bits.
> We are planning to upgrade in June to a z box 
> (z800) as you suggest, but in the meantime we 
> would like to use 6 or 7 VM under Linux/390 under 
> z/VM 4.2.0 on our multiprise 3000 model  H30.
> Still a problem with Lenny ...
> This time, CP does not go into "interrupt loop", 
> but seems to compute forever after "IPL 000C CLEAR".
> It says "03 FILES CHANGED" and then no messages appear.
> I don't think it would be useful to write to the 
> whole list as this moment, because I saw nobody 
> but you answering questions precisely. Maybe we 
> should if the next trial also fails, after all!
> Many things for the detailed info. I keep it in this
> e-mail for the moment.

I don't mind if you CC debian-s390@lists.debian.org, because that is
where this discussion belongs.  But please don't send a copy to the bug
log for bug 621080.  That is a totally unrelated bug report.  Your long,
unrelated post to that bug log has no doubt annoyed the maintainer and
reduced my chances of getting the enhancement request.  I'm not sure how
that happened.  Perhaps you tried to "reply to all" to a post on the list.
What you should have done is start a new thread.  Please submit a *short*
apology to 621080@bugs.debian.org for the unrelated and unintended post.

There are others who answer questions on the s390 list besides me.
But the real point is that someone else may have a similar problem
to yours a few months from now.  If I help you in a private e-mail, I
solve your problem.  But if I help you on the list, someone else searching
the internet may find it.  We have to think of others too and not just

I cannot reproduce your problem because I don't have the hardware (Multiprise
3000) or the software (z/VM 4.2.0) to reproduce your problem.  My hardware
is a z/890 and I run z/VM 5.4.0.  So at the risk of insulting your intelligence,
I will explain the installation steps in detail.  Maybe there's something you're

(1) Choose a Debian mirror.  I will use ftp.uwsg.indiana.edu in this example.
You'll probably want to use a mirror closer to home.  For a full list of
Debian mirrors, see http://www.debian.org/mirrors/list.

(2) Logon to the virtual machine that you will install to and IPL CMS.
Make sure that the TCP/IP client code disk is accessed (TCPMAINT 592).
Make sure that the "A" disk is large enough to handle the downloads.
>From a CMS "Ready;" prompt, issue


FTP ftp.uwsg.indiana.edu
binary f 80
cd /linux/debian
cd dists/lenny/main/installer-s390/current/images/generic
get kernel.debian KERNEL.DEBIAN
get initrd.debian INITRD.DEBIAN
get parmfile.debian PARMFILE.DEBIAN
get debian.exec DEBIAN.EXEC


I assume that z/VM 4.2.0 includes CMS Pipelines.  I can't remember.
If not, then the PIPE command will not work.  In that case you will
have to manually edit DEBIAN EXEC A to remove the X'25' characters
(EBCDIC line feed characters) and split the lines.  I tried it
yesterday, and it works on my hardware.  I verified that the Lenny
installer does indeed use a 31-bit kernel (2.6.26-2-s390)
and not a 64-bit kernel (2.6.26-2-s390x); so, in theory, it should work.

You will perform the first few steps, such as configuring the network
device and configuring the network, from the virtual 3215 console.
After that, you must continue the installation by logging in remotely
using an SSH client.  If your desktop operating system is Windows,
I recommend PuTTY as the SSH client.  It is free software from Simon
G. Tatham, available here:


I use a virtual OSA in QDIO mode (a NICDEF entry in the CP directory
which is attached to a virtual switch) as the network device for my
virtual machines, but I don't know if that's supported in z/VM 4.2.0.
The installer only supports three types of network devices: a
channel-to-channel adapter, an Open Systems Adapter, and an IUCV
connection.  You have to use one of those three.  Once you're installed,
you may have other choices.

Make sure PuTTY is set up to use UTF-8 as the character set during
installation.  Otherwise, the scroll bars, outline boxes, etc., will
look terrible.  After installation you can switch to another character
set, depending on the locale chosen.

Good luck.

  .''`.     Stephen Powell    
 : :'  :
 `. `'`

Reply to: