[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: git t7400.24 is failing again

On Thu, 25 Mar 2010 11:03:01 -0400 (EDT), Jonathan Nieder wrote:
> Stephen Powell wrote:
>> The only thing I know of that changed recently is the switch
>> to a 64-bit kernel by the build server for s390.  (I am just a regular
>> Joe Schmoe user.  I'm not a Debian package maintainer, Debian Developer,
>> or any other kind of official Debian person.  So consider the source.)
> That sounds relevant indeed (and unfortunate for my efforts to
> reproduce: I haven’t been able to get a 64-bit kernel running on this
> emulated machine).  Thank you; I’ll think harder.

If you're using Hercules, you have to define the the machine in Hercules
as a 64-bit machine, such as a z800, z900, etc.  A 64-bit kernel won't
run on an ESA/390 processor.  I am fortunate enough
to have a real mainframe, a z890; so I don't need to use Hercules.
The z890 has an LPAR with a dedicated IFL processor, I run z/VM 5.4.0
in the LPAR, and then I run Linux in a virtual machine under z/VM.
I believe the build server for s390 runs Squeeze/Sid, and uses a
kernel such as linux-image-2.6.32-3-s390x, linux-image-2.6.32-4-s390,
or something close to that.

As far as I know, which isn't very far, the user space is still 32-bit
for register size and 31-bit for addressing.  But the kernel space
is 64-bit.  Again, I'm speaking exclusively of the s390 architecture
here.  Someone please correct me if I'm wrong.

Note: please reply to the BR and the list, not to me personally.
Not only is information missing, but it messes up the threads when
you do that.  This reply will probably start a new thread, since my
e-mail client doesn't give me a way to override the "Reply-To" field.
Ideally, it should be a continuation of the old thread.

  .''`.     Stephen Powell    <zlinuxman@wowway.com>
 : :'  :
 `. `'`

Reply to: