[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[RFH] Installer fails to boot from CD

Hi all,

As reported yesterday by Larry Martin, Debian Installer fails to boot
from CD on s390.

I worked on that early in the Etch release cycle [1] and when it was
implemented in debian-cd it worked fine. But if I now try an Etch
image, that fails as well. The problem seems to be that it fails to
recognize the initrd and thus fails to mount the root fs.

From a boot from an Etch CD:
checking if image is initramfs...
it isn't (bad gzip magic numbers); looks like an initrd
RAMDISK: Compressed image found at block 0
No filesystem could mount root, tried:  ext3 ext2 cramfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

I've looked at the changes during Etch, and the most likely cause of
the failure is that later in the Etch cycle we switched from an ext2
initrd to initramfs.

The way we boot from CD is by IPLing d390.ins, which has:
$ cat d390.ins
* Debian GNU/Linux for S/390 (boot from CD-ROM or FTP-Server)
linux_vm 0x00000000
parmfile 0x00010480
root.bin 0x00800000

linux_vm is identical to generic/kernel.debian; root.bin is identical
to generic/initrd.debian (and is a valid initramfs).

If I create a 3505 (RDR) device in Hercules with
   linux_vm parmfile root.bin autopad eof
the identical images boot correctly.

Does anyone know how to set up the CD correctly for booting using an


[1] http://bugs.debian.org/318021

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: