[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing PHP4

Silly me! I thought it would be named mod_ssl!
No hits on debian.org for anything by that name!

No, I don't care about version numbers per se, but between mod_ssl
for Apache 1.3.26 and the current one for Apache 1.3.28 there have
been several bugfixes and one security fix, so why would anyone
install the old one that has bugs and security problems, especially
when the package is a security feature???

I will install libapache-mod-ssl and see how that works.

As for getting modules from anywhere but stable, I have no
idea how to do that!


                    Matt Zimmerman                                                                                                         
                    <mdz@debian.or       To:     debian-s390@lists.debian.org                                                              
                    g>                   cc:                                                                                               
                    Sent by: Matt        Subject:     Re: Installing PHP4                                                                  
                    01:40 PM                                                                                                               

On Thu, Sep 18, 2003 at 11:52:02AM -0500, Dennis Wicks wrote:

> Thanks for the reply, but, what I really started on was installing
> mod_ssl. No package for that.

Er...where did you look?  It's been in Debian for about four years now.

cthulhu:[~] apt-cache search mod_ssl
libapache-mod-ssl - Strong cryptography (HTTPS support) for Apache
libapache-mod-ssl-doc - Documentation for Apache module mod_ssl

> the deb pkg for apache is too far back level for the latest mod_ssl that
> contains "Important bugfixes."
> So, I installed apache by hand.
> Then, I'd like to have php to experiment with, and the package is
> 4.1.2 while the latest stable release is 4.3.3 and anyway the
> package probably won't install correctly with the hand-installed
> apache!
> The upshot is that I have yet to be able to do any useful installs
> or upgrades from packages, rpms, etc. They are generally too far
> back-level to have the features I need.

If version numbers are more important to you than a stable and
well-integrated system, then you will always have this problem.  The fact
is, you're bypassing the value that Debian releases provide, which is to
make all of these things work together.

If you need more current versions (for specific features and fixes, not for
higher numbers), then you can always get these, in packaged and integrated
form, from unstable.

 - mdz

To UNSUBSCRIBE, email to debian-s390-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Reply to: