[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dchroot on trex



On Sunday 25 August 2002 00:28, Stefan Schwandter wrote:
> Hello!
>
>
> I'd like to build openmotif on s390, because I need it for snd-motif.
> I tried to build it in the unstable chroot. Is it normal that I don't
> have a username when I'm in it (the bash prompt shows "I have no
>
> name")?

No, that's not normal. I am not sure but this may be caused by an ldap 
replication problem/delay. /var/lib/misc/trex.debian.org/passwd is from Aug 8 
and your debian id seems to have been created later than that. Ryan, do you 
have any idea?

> Apparently I can't run dpkg-buildpackage for this reason:
> : unable to get login information for username "swan" at
> : /usr/lib/dpkg/controllib.pl line 56. Compilation failed in require at
> : /usr/bin/dpkg-parsechangelog line 15.
>
> , so I tried to build by running debian/rules binary-arch manually.
>
> I noticed that some build-deps, namely libxaw7-dev and byacc, are also
> missing.
>
> Maybe someone could a) install libxaw7-dev and byacc in the unstable
> chroot, 

Done.

> and b) explain to me how I can run dpkg-buildpackage in the
> fakeroot (or point me somewhere this is explained)? That would be very
> appreciated! :-)
>

Gerhard



Reply to: