[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tarball of base filesystem

On Mon, Jun 11, 2001 at 11:19:48AM +0200, Yves Rougy wrote:
> Date: Mon, 11 Jun 2001 11:19:48 +0200
> From: Yves Rougy <yves.rougy@fr.alcove.com>
> Richard Higson(richard.higson@gt.owl.de)@Sun, May 27, 2001 at 01:06:12PM +0200:
> > On Sat, May 26, 2001 at 07:24:30PM +0200, Gerhard Tonn wrote:
> > > I have uploaded a tarball of the base filesystem to
> > > http://source.rfc822.org/pub/mirror/s390-ibm-linux/debian-s390.
> > > It is called base-s390.tar.gz. It should help at least to setup a chroot 
> > > environment.
> > I tried to chroot to it on a CAIMAN system running on my laptop.
> > It doesn't seem too happy.
> > 
> > Linux DEB390 2.2.16 #1 SMP Tue May 15 11:53:02 KST 2001 s390 unknown
> > bash: /DEB390/bin/true: cannot execute binary file
> > syslog said "modprobe: Can't locate module binfmt-4c46"
> > That looks familiar ... 
> Well I have the same problem on a TurboLinux... How did you solved the
> problem ?

This happens when the kernel is generated by a gcc which is much older than the
gcc used to create the binaries (which depend partly on the kernel headers).

Don't ask me 'exactly how much older', I think it's the difference between 2.95.2 and 2.95.3.

It's a chicken & egg problem.
I then build myself a 2.2.19 Kernel with a "recent" gcc and it worked.

This one is OK
higson@cyclops:~$ gcc -v
Reading specs from /usr/lib/gcc-lib/s390-linux/2.95.3/specs
gcc version 2.95.3 20010111 (prerelease)

Same here.
higson@debian.s390.org gcc -v
Reading specs from /usr/lib/gcc-lib/s390-linux/2.95.3/specs
gcc version 2.95.3 20010315 (Debian release)

the gcc on zseriespenguins.ihost.com (down again) is too old, and produces the 
binfmt-4c46 error(s)

Unix:        Your gun, Your bullet, Your foot, Your choice.
M$-CE/ME/NT: Same as Unix, BUT: No choice, and We Aim Higher.
Have a nice day ;-) Richard Higson mailto:richard.higson@gt.owl.de

Reply to: