[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tarball of base filesystem

> > > syslog said "modprobe: Can't locate module binfmt-4c46"
> > > That looks familiar ... 
> This happens when the kernel is generated by a gcc which is much older than the
> gcc used to create the binaries (which depend partly on the kernel headers).
> Don't ask me 'exactly how much older', I think it's the difference between 2.95.2 and 2.95.3.
> It's a chicken & egg problem.
> I then build myself a 2.2.19 Kernel with a "recent" gcc and it worked.
> This one is OK
> higson@cyclops:~$ gcc -v
> Reading specs from /usr/lib/gcc-lib/s390-linux/2.95.3/specs
> gcc version 2.95.3 20010111 (prerelease)
> Same here.
> higson@debian.s390.org gcc -v
> Reading specs from /usr/lib/gcc-lib/s390-linux/2.95.3/specs
> gcc version 2.95.3 20010315 (Debian release)
> the gcc on zseriespenguins.ihost.com (down again) is too old, and produces the 
> binfmt-4c46 error(s)

Well, I tried to compile gcc on zseriespenguins.ihost.com (turboLinux)
with hope to compile a new kernel on it...
After many tries, I cannot compile it, I have a "/tmp/cc8Jr3BN.s:278:
Error: Unrecognized opcode: `jhe'" error with with s390 patch
from IBM, or with 2.95.4 from the Debian sources (and patches applied)... 

I cannot find s390 patches for 2.95.3... Did you made it from 95.2 s390
patch ? (I am not really a gcc hacker...)

Any idea to success the compilation of a "recent" gcc ?


Yves ROUGY - Yves.Rougy@fr.alcove.com
Coordinateur du Laboratoire - Lab Manager
Ingénieur Logiciels Libres - Open Source Software Engineer

Alcôve "L'informatique est libre" http://www.alcove.com

Reply to: