[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: test case failing with ruby 1.9.1 with dust



On 22/08/11 at 12:06 +0530, Praveen A wrote:
> [please cc me on replies]
> 
> A few of us in Debian India community is trying to get diaspora
> packaged. I have started with systemtimer and it needs dust for tests.
> I get the following error with ruby 1.9.1, all tests pass with ruby
> 1.8. Can anyone help me to fix it?
> 
> /usr/bin/ruby1.9.1 -I/usr/lib/ruby/vendor_ruby
> /usr/lib/ruby/vendor_ruby/gem2deb/test_runner.rb
> Running tests for ruby1.9.1 with test file list from
> debian/ruby-test-files.yaml ...
> :helper_method
> /tmp/buildd/ruby-dust-0.1.6/test/failing_with_setup_unit_test.rb:11:in
> `<top (required)>': shouldn't be here (RuntimeError)
> 	from <internal:lib/rubygems/custom_require>:29:in `require'
> 	from <internal:lib/rubygems/custom_require>:29:in `require'
> 	from /tmp/buildd/ruby-dust-0.1.6/test/all_tests.rb:1:in `block in
> <top (required)>'
> 	from /tmp/buildd/ruby-dust-0.1.6/test/all_tests.rb:1:in `each'
> 	from /tmp/buildd/ruby-dust-0.1.6/test/all_tests.rb:1:in `<top (required)>'
> 	from <internal:lib/rubygems/custom_require>:29:in `require'
> 	from <internal:lib/rubygems/custom_require>:29:in `require'
> 	from -e:1:in `block in <main>'
> 	from -e:1:in `each'
> 	from -e:1:in `<main>'
> ERROR: Test "ruby1.9.1" failed. Exiting.

Hi,

It's likely to be a problem in dust. Have you tried reproducing the
problem outside of the gem2deb test harness ?

I suggest you talk to dust developers.

L.


Reply to: