[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: About the Ruby packages split: a concrete proposal

At first, thank you for some proposals and many comments about
ruby1.8-packages.  And I am sorry for my late reply.

My proposal about restructuring of ruby1.8-packages is below:

  - new libruby1.8 will have ruby libraries which package depends on
    "priority: required" packages, that is, libruby1.8 merges
    libsdbm-ruby1.8, libdl-ruby1.8, libpty-ruby1.8, libbigdecimal-ruby1.8,
    libsyslog-ruby1.8, libstrscan-ruby1.8, libiconv-ruby1.8,
    libracc-runtime-ruby1.8, libdrb-ruby1.8, liberb-ruby1.8,
    libtest-unit-ruby1.8, librexml-ruby1.8, libxmlrpc-ruby1.8,
    libsoap-ruby1.8, libwebrick-ruby1.8, libyaml-ruby1.8, libzlib-ruby1.8
    and libcurses-ruby1.8.

    Of course, libruby1.8 provides/replaces/conflicts the packages.

  - libtk-ruby1.8 merged to libtcktk-ruby1.8.

    new libtcktk-ruby1.8 provides/replaces/conflicts libtk-ruby1.8.

  - other packages (ruby1.8, libruby1.8-dbg, ruby1.8-dev,
    libreadline-ruby1.8, irb1.8, rdoc1.8, ri1.8, libopenssl-ruby1.8,
    libdbm-ruby1.8, libgdbm-ruby1.8, ruby1.8-elisp and ruby1.8-examples) are
    left as it is.

  - ruby1.8 suggests or recommends rdoc1.8 and ri1.8

  - packages of ruby-defaults also follows this new naming scheme.

I think that "apt-get install ruby" should enable you to use most features
of Ruby language.  But I think also that it should not install many packages
by dependency.

"Most" is the point under discussion.  Someone may wish "ruby" means all
packages of ruby upstream, someone may wish "ruby" means ruby interpreter
and a few extension libraries, others may wish "ruby" means only mod_ruby
(libapache-mod-ruby and libruby1.8).  So It is difficult for me to accept
changing the meaning of "ruby" (and ruby1.8), ruby1.8-stdlib, ruby1.8-core,
ruby1.8-interpreter, etc.

But ruby1.8-bundle is acceptable.
(http://lists.debian.org/debian-ruby/2005/01/msg00011.html) Its meanings is
clear for everyone.

I classified ruby1.8-packages by priority of packages that the package
depends on.  (And I made the proposal in above.)  The result is:

  depends: required package only

    - libruby1.8
    - ruby1.8
    - libsdbm-ruby1.8
    - libdl-ruby1.8
    - libpty-ruby1.8
    - libbigdecimal-ruby1.8
    - libsyslog-ruby1.8
    - libstrscan-ruby1.8
    - libiconv-ruby1.8
    - libracc-runtime-ruby1.8
    - libdrb-ruby1.8 (all)
    - liberb-ruby1.8 (all)
    - libtest-unit-ruby1.8 (all)
    - libruby1.8-dbg
    - ruby1.8-dev
    - librexml-ruby1.8 (all)
    - libxmlrpc-ruby1.8(all)
    - libsoap-ruby1.8(all)
    - libwebrick-ruby1.8(all)
    - libyaml-ruby1.8
    - libzlib-ruby1.8
    - libcurses-ruby1.8

  depends: required package and libreadline4

    - libreadline-ruby1.8
    - irb1.8
    - rdoc1.8
    - ri1.8

  depends: required package and libssl0.9.7

    - libopenssl-ruby1.8

  depends: required package and libgdbm3

    - libdbm-ruby1.8
    - libgdbm-ruby1.8

  depends: required package, libx11-6 or xlibs, tcl8.4 and tk8.4

    - libtcltk-ruby1.8
    - libtk-ruby1.8

  depends: emacsen

    - ruby1.8-elisp

  recommends: ruby1.8

    - ruby1.8-examples


Packages which have version depends on packages which depends on "libc6 and
required package":

  $ grep-available -Fdepends -spackage -e '(ruby1\.8-dev|lib(sdbm|dl|pty|bigdecimal|syslog|strscan|iconv|racc-runtime|drb|erb|test-unit|rexml|xmlrpc|soap|webrick|yaml|zlib|curses)-ruby1\.8) \('
  package: libdrb-ruby
  package: libiconv-ruby
  package: libbigdecimal-ruby
  package: liberb-ruby
  package: libxmlrpc-ruby
  package: libzlib-ruby
  package: libyaml-ruby
  package: libstrscan-ruby
  package: libracc-runtime-ruby
  package: rdoc1.8
  package: libtest-unit-ruby
  package: libdl-ruby
  package: libwebrick-ruby

Packages which have version depends on libtcktk-ruby1.8 or libtk-ruby1.8:

  $ grep-available -Fdepends -spackage -e 'lib(tcktk|tk)-ruby1\.8 \('
  (not found)

Thank you.
akira yamada       <URL:http://arika.org>

Reply to: