[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#786500: nmu: alberta_3.0.1-1



Package: release.debian.org
Severity: normal
User: release.debian.org@packages.debian.org
Usertags: binnmu

Hi,

libalberta uses a relocation type that should not be used for shared
libraries on powerpc[1] which makes the library unusable. As the build
log looked okay to me and the older version (3.0.0-3) worked, I tried
rebuilding the package on partch.d.o and the bad relocations
disappeared... At least "readelf -a" no longer showed any occurence of
"R_PPC_REL24".

I'm wondering if this was some issue with an older version of the
toolchain; note that alberta uses clang instead of gcc as gcc has a
bug (see link in [1]).

Could you please schedule a binNMU for alberta on powerpc to get it
rebuilt with the current toolchain? Please also consider giving back
dune-grid/2.4~20150506gd3c1350-1 on powerpc in experimental with an
additional build-dep on the binNMU'ed libalberta-dev (>= 2.3.1-1+b1)

Ansgar

nmu alberta_3.0.1-1 . powerpc . -m "Rebuild with current toolchain."
gb dune-grid_2.4~20150506gd3c1350-1 . powerpc . experimental
dw dune-grid_2.4~20150506gd3c1350-1 . powerpc . experimental -m "libalberta-dev (>= 2.3.1-1+b1)"

(Not sure if gb/dw are correct like this.)

  [1] <https://lists.debian.org/debian-powerpc/2015/05/msg00061.html>


Reply to: