[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#681327: unblock: modsecurity-apache/2.6.6-2

On 2012-07-12 12:21, Alberto Gonzalez Iniesta wrote:
> Package: release.debian.org
> Severity: normal
> User: release.debian.org@packages.debian.org
> Usertags: unblock
> Please unblock package modsecurity-apache
> A change in the license went unnoticed. Just debian/copyright was
> updated.
> debdiff attached.
> unblock modsecurity-apache/2.6.6-2
> -- System Information:
> Debian Release: wheezy/sid
>   APT prefers unstable
>   APT policy: (500, 'unstable')
> Architecture: i386 (i686)
> Kernel: Linux 3.2.0-2-686-pae (SMP w/2 CPU cores)
> Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/dash

+ [...]; either version 2 of the License.

Did you mean "either version 2 or (at your choice any) later version of
the License"? (or however it is written...)

According to your copyright file, any Debian patches will be under GPL-2
and cannot be applied.  However, the Apache2 license is not compatible
with GPL-2 (it seems to be with GPL-3)[1].

[1] http://www.apache.org/licenses/GPL-compatibility.html

Despite our best efforts, the FSF has never considered the Apache
License to be compatible with GPL version 2, citing the patent
termination and indemnification provisions as restrictions not present
in the older GPL license.

Reply to: