[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#673538: libobjc3 -> libobjc4 transition

On Fri, 2012-06-29 at 21:20 +0300, Yavor Doganov wrote:
> Adam D. Barratt wrote:
> > My understanding was that if necessary (which given that the freeze is 
> > tomorrow it might be), this could be resolved without a transition by 
> > having gnustep-make explicitly depend on gobjc-4.6 for the wheezy cycle; 
> > see #676229.
> You are not correct that we'll have to revert the change in
> gnustep-make (the dependency on gobjc-4.6).
> Uploading gnustep-base/1.22.1 with the libobjc4 patch will allow the
> package to be built with gcc-4.7 on x86 archs, and with gcc-4.6 on the
> other (where 4.6 is still the default).  Thus, all GNUstep packages
> that were recently built will depend on libobjc4 on x86, and on
> libobjc3 on the rest of the architectures, as is expected.  The patch
> is ABI compatible, so no recompilation should be necessary; I can
> confirm this after my runtime tests.

That would presumably be one or both of the patches from
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=667868#12 ?  If we
postponed the main transition(s) until wheezy+1, would the gnustep-base
upload be the only thing required for wheezy?



Reply to: