[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pygame

On Mon, 2012-01-02 at 11:03 +0100, A Mennucc wrote:
> (Indeed pygame 1.9.x depends on portmidi, that currently does not build
> on kfree-*
>  https://buildd.debian.org/status/package.php?p=portmidi
> )
> But why does http://packages.qa.debian.org/p/pygame.html
> report "valid candidate" , and it says that "upgrading breaks monsterz"?
> (should I post a bug against p.qa.d.o ? against what?)

"Valid candidate" means the package itself (i.e. pygame) meets the
criteria for migration (it's up-to-date on all architectures for which
binaries exist in unstable, doesn't have RC bugs filed against it, has
been in unstable for long enough, ...).  However, due to the lack of
kfreebsd-* binaries, migrating the new pygame would cause the current
kfreebsd-* binaries for monsterz in testing to become uninstallable.
Both of these statements are correct; there is no contradiction.

As I said earlier, either a solution needs to be found that allows
pygame to build on kfreebsd-* again, or its reverse dependencies need to
be fixed to not depend on it on kfreebsd-* (including their not existing
on those architectures, if need be).



Reply to: