[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#604855: unblock: shibboleth-sp2/2.3.1+dfsg-3



Mehdi Dogguy <mehdi@dogguy.org> writes:
> On 11/24/2010 10:02 PM, Russ Allbery wrote:

>> Please unblock package shibboleth-sp2.  This package includes both a
>> daemon and an Apache module, and those need to be in sync following an
>> upgrade or strange problems can result.  This version adds code to
>> postinst to restart Apache after upgrading the Apache module so that
>> the newly restarted shibd daemon will match the Apache module.

> Shouln't you check that apache2 is installed before trying to restart
> it?

Ah, hm, that's a good point.  I hadn't thought about that, since the old
Shibboleth modules depended on Apache.  But the current packages only
recommend.

I'm not sure the best way to do this.  Check for whether apache2.2-common
is installed, since it contains the init script?  (Checking for the
existence of the init script may be a lurking bug later for upstart
systems, file-rc, systemd, etc.)  Alternately, we could just ignore
failures on the invoke-rc.d command to restart Apache.

Does anyone have any suggestions about the best approach?

-- 
Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>



Reply to: