[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#591924: postgresql-common - insserv: script postgresql: service postgresql already provided!

Hello all,

Julien Cristau [2010-11-20 19:58 +0100]:
> On Sat, Nov 20, 2010 at 19:44:49 +0100, Martin Pitt wrote:
> > Waiting for -release ack before I upload this.
> > 
> Sounds like that's the least bad way to go, so ack.

Uploaded. The change for this bug fix is rather straightforward:

I tested this with unmodified and modified /etc/init.d/postgresql-8.3
and confirm that an upgrade from lenny's versions to postgresql-common
112 now cleans up the obsolete conffile and lets the upgrade succeed.

I already had another bug fix for #509050 in bzr head, which I
uploaded along. The changes are a tad more intrusive, since I had to
fix some broken logic in several places, but they are all properly
test-case'd and I have run with them locally for some time now. I am
very confident in them, but if you rather prefer not to have them, I
can do a t-p-u upload with just the fix for this bug. For reference I
attach a complete debdiff.

Can you please allow postgresql-common 112 into squeeze?

Thank you,

Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)

Attachment: signature.asc
Description: Digital signature

Reply to: