[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#603760: Pre-approval for unblock of nvidia-graphics-drivers/195.36.31-6



Package: release.debian.org
Severity: normal
User: release.debian.org@packages.debian.org
Usertags: unblock

Hello folks,

Upgrade testing on nvidia-graphics-drivers has uncovered the following
additional issue and I wanted to check whether you feel that an upload
of a new package for squeeze is warranted.  The changelog is:

  * If both original and diverted file exist when removing obsolete
    diversions, move the original file (which is not owned by any package) out
    of the way.  This problem may originate from incorrect diversion creation
    before lenny (and was not noticed or fixed in lenny) or having used the
    nvidia installer to install the driver in the past.  (Closes: #600327)

As with most upgrade problems, the severity is hard to determine; people
who have this problem won't be able to upgrade cleanly, so it breaks the
package for them, but it doesn't affect many systems.

If we were to upload a new package, we would also include the following
additional documentation fixes:

  * Add a NEWS entry recommending to update all pre-squeeze nvidia packages
    before switching to a -legacy- variant.  (Closes: #596843)
  * Update gdm/kdm insufficient timeout NEWS entry: mention xdm (no workaround
    needed) and that kdm was fixed in 4:4.4.5-4.
  * Document the warnings emitted by the maintainer scripts in README.Debian.
  * Install the upstream README.txt in the dkms package.  It is referenced by
    the package description.  Add a README.Debian, too.  (Closes: #602733)

If this looks okay, let me know, and I'll upload 195.36.31-6 to unstable.
Let me know if you'd like a diff of the change described above.

Thanks!

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686-bigmem (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash



Reply to: