[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New "translation update" for pioneers



Op 26-10-10 20:14, Julien Cristau schreef:
> On Sat, Oct 23, 2010 at 20:00:35 +0200, Bas Wijnen wrote:
> 
>> +#if (GTK_MAJOR_VERSION <= 2 && GTK_MINOR_VERSION <= 18 &&
>> GTK_MICRO_VERSION < 2)
>>         GtkWidget *button;
>> +#endif
>>
> That check seems broken, it will consider, say, 2.12.12 as fixed.

Good catch! These sort of things are the reason I might better include
only the translations. :-)

> It's also a build time check instead of a runtime one...

Hmm, I suppose it is possible to run the executable with a lower version
of the library than was used to compile it. It's not using any symbols
which are new in 2.18.2, so dpkg-shlibdeps will generate a dependency on
a lower version, right? In that case we do indeed need a runtime check.

Roland, I think it's best if I make any required changes for this Debian
package, and we include them in the next release (which will not go into
squeeze) separately. What do you think?

Thanks,
Bas

Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: