[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dropping libdevkit-power-gobject for squeeze.

On Wed, 2010-09-15 at 08:56 +0200, Michael Biebl wrote:
> libdevkit-power-gobject is the old ABI that was provided by DeviceKit-power.
> DeviceKit-power has been replaced by UPower.
> UPower though still provides the old ABI via a compat lib, which I'd like to get
> rid of in squeeze (this compat lib will also be removed in the next upstream
> version of UPower, i.e. there will be no more support from upstream).

Apologies for failing to follow-up on this after the initial response.

> Currently there are 4 packages remaining (in squeeze) that still depend on
> libdevkit-power-gobject:
> - gdm3 2.30.2-4
> - tracker 0.8.15-1
> - gnome-session 2.30.2-1
> - gnome-power-manager 2.30.1-1

gnome-session 2.30.2-2 is now in testing, and no longer depends on
libdk-p-g; gdm3 is unblocked and waiting to age.  As discussed on IRC, a
g-p-m 2.32 upload may be possible, depending on what the diff looks

I see that tracker 0.8.17 has been uploaded in the meantime.  Were you
planning on requesting an unblock for that?  After excluding changes to
the testsuite, translations, documentation, the autotools update and the
upower patch itself (as the actual changes therein are rather small), we
end up with

 58 files changed, 757 insertions(+), 519 deletions(-)

which isn't /that/ big, but I didn't evaluate the changes in any detail.



Reply to: