[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#597880: unblock: python-stdlib-extensions/2.6.6-1

On Fri, October 8, 2010 11:26, Matthias Klose wrote:
> On 08.10.2010 10:59, Adam D. Barratt wrote:
>> The only change in python-stdlib-extensions appears to be the version
>> number, so I was simply querying whether there was some reason I'd
>> missed that it was technically necessary for all of the involved
>> packages to have exactly the same version number if there was no
>> functional change between 2.6.5-1 and 2.6.6-1.
> No, I don't know of any functional change.  I'm just waiting for the first
> bug report that the version numbers don't match.

The reporters of such bugs should probably be told not to be so fixated on
version numbers... in any case, unblocked.

> The only package I know that depends on the subminor version number is the
> apache plugin.

That would explain #592988; I assume that just needs a round of binNMUs.

> But I assume that somebody did take care of this when
> approving the migration of 2.6.6 to testing.

How would they have known?  The dependencies of libapache2-mod-python only
specify "libpython2.6 (>= 2.6), python (<< 2.7), python (>= 2.6)" which
provides no hint at all that they need a more specific version (and smells
rather like an RC bug in that package).



Reply to: